Raptor
Avatar Raptor
Themenersteller
IT-Student
Content Gott (1013 Beiträge)

RSS will nicht

am 09.06.2009, 10:34 Uhr eröffnete Raptor folgenden Thread
Forum    2538 mal gelesen    2 Antwort(en).

Wenn ich die RSS-Seite aufrufe, bekomme ich folgenden Fehler im Firefox:

XML-Verarbeitungsfehler: XML- oder Text-Deklaration nicht am Beginn der Entität
Adresse: www.seitenreport.de/forum/rss-feed.html
Zeile Nr. 2, Spalte 8


Ist zwar die billigste Fehlermeldung, die ich jemals bekommen habe, aber es hindert mich daran das RSS zu abonnieren.


Meine Developer-Website mit den Web-Entwickler-Tools.
Meine Web-Entwicklungs-Dienstleistungen

[url="http://www.seitenreport.de/forum/beitraege/seitenreport_verlosungen/wichtig_neue_regel


gelöschter Benutzer
am 09.06.2009, 11:02 Uhr schrieb

Der Grund ist auch so billig wie die Fehlermeldung selbst.

Der Feed fängt mit einem Zeilenvorschub an und das

<?xml version="1.0" encoding="iso-8859-1"?>

hat noch führende Leerzeichen - "tödlicher Fehler" bei XML.

Ausserdem sind die Zeichen hier in utf8 kodiert im Feed iso-8859-1, d.h. alle Umlaute sind falsch.


seitenreport
Avatar seitenreport
Inhaber
TYPO3 Senior Developer
Content Gott (1771 Beiträge)
am 09.06.2009, 12:33 Uhr schrieb seitenreport

Eine der TYPO3-Extensions fügt hier einen Whitespace überall vor der HTML ein (sieht man z.B. auch, wenn man einfach den Quellcode der normalen Seite anschaut).

Dadurch ist der RSS-Feed natürlich durch die eine Leerzeile am Anfang nicht mehr valide und kann z.B. vom Firefox RSS nicht mehr abonniert werden. :evil:

Hilft nichts, da muss ich alle Extension-Dateien durchgehen, um die "fehlerhafte" Extension zu finden => wird natürlich einige Zeit dauern. Wird soweit ich das sehe die EXT:mm_forum sein. grummel.



SEO Analyse und Website-Check mit Seitenreport

  • 1


« zurück zu: Forum

Das Seitenreport Forum hat aktuell 5267 Themen und 36089 Beiträge.
Insgesamt sind 48167 Mitglieder registriert.